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1. Introduction
With m/matl, you can create, modify and visualize the material definition and cross section
of EM stack-ups for use with the Sonnet EM simulator. For easy re-use of existing
technology definitions, you can import and export from/to various other file formats.
If you need to support one semiconductor technology with multiple design flows, such as
Cadence Virtuoso based and GDSII file based, you can use m/matl as the single source for
all required technology, template and layer mapping files.

2. What file formats and design flows are supported?
Read & write *.matl
The primary file format for m/matl is the Sonnet *.matl file format, as used in Sonnet's
interfaces to Cadence Virtuoso and Agilent ADS. The *.matl file includes all required
information for using Sonnet in a Virtuoso or ADS workflow: metal, via and dielectric
definitions and their position in the stack-up, along with the respective Cadence/ADS layer
names.
To enabled m/matl as a single data source for multiple design flows, we have extended
Sonnet's *.matl file format, to also store optional layer mapping information for other file
formats. These optional GDSII and DXF mappings in the *.matl file have no side effect
when the file is used with Cadence and ADS workflows, they are simply ignored.

Read existing *.son simulation models
You can import *.son files into the m/matl editor. Contrary to the *.matl file, the metal and
via definitions in an empty *.son project do not specify the actual position in the stack-up.
If the imported project includes actual geometries along with the material definitions,
m/matl will evaluate their stack-up position and the used metal and via defintions, to
identify which metal/via definitions are used in which stack-up position. If the imported
Sonnet project is empty, with no geometries, there is no way how the software can
identify the corresponding levels for metals and vias. In this case, you must assign the
stack-up positions manually.
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Export *.son and *.lay for Sonnet GDSII workflow
When using Sonnet with GDSII data, the Sonnet project editor xgeom can import the GDSII
geometries with a template (empty Sonnet project) that holds the dielectric stack-up and
metal and via definitions. Contrary to the *.matl file, only the conductor properties are
defined in the template, but not their position in the stack-up. This data is supplied during
the GDSII import process with an additional file, the layer mapping file (*.lyr).
To summarize: in a GDSII workflow, we need a *.son template file with the material
definitions and a *.lay layer mapping file. With m/matl, you can create these files.
The required GDSII layer numbers must be defined from the m/matl metal and via dialogs,
because they are not part of the usual *.matl information. However, once it is defined in
m/matl, the information can be stored along with all other data in our extended *.matl file
format.

Export *.son and *.lyr for Sonnet DXF workflow
The DXF workflow is similar to GDSII, with a *.son template and a layer mapping file.
For DXF, the layer mapping file is *.lyr and uses a different syntax than the GDSII layer
mapping file.

Export *.gym for Empire XCcell 3D EM workflow
With this export option, you can create an empty project (template) for the Empire XCcell
3D EM simulator. The template includes the dielectric and material definitions. Dielectrics
are included, with the x and y dimensions as defined in m/matl under File > Preferences >
Cell Size and Box size. Dielectric size is Cell Size x Number of Cells.
Note that simulation settings default to lossless metal and lossless dielectrics, so you have
to set these (and other) simulation settings manually.
Status of the Empire XCcell export option is: experimental
Carefully check the models that you have created with this option.
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Export *.subst for ADS 2011 workflow
The new March 2013 release now introduces support for ADS 2011 *.subst files, which can
be imported and exported.
IMPORTANT:
Unlike the old *.slm files, you cannot easily move/copy the ADS 2011 substrate files!
The *.subst file does not include the full EM stackup information, and references the shared
material definitions file. That shared file materials.matdb is always located in the same
directory as the *.subst file, and has all material definitions for all substrates in this library.
Thus, if you just copy it around, this will have side effects on the other substrate files!
The location for all substrate files is the library folder. When m/matl exports an ADS 2011
substrate file, the corresponding material definitions are appended to materials.matdb.
If materials.matdb does not yet exist, it is created. If you have multiple substrate files in
one library, make sure that you export to that shared file location, because that will append
the material definitions to an existing materials.matdb.
Another detail to be aware of with ADS 2011 substrate files: The layer names for metals
and vias must be specified by the layer number, not the layer name. This is caused by
Agilent’s definition of the *.subst file.
To set the Agilent layer number for metals and vias in m/matl, use the GDSII layer
input field. We decided to share that setting because in RFIC/MMIC technologies, we
often have ADS layer name = GDSII layer name. By referencing the GDSII layer number
setting, we can easily export existing m/matl substrate file with GDSII layer number to
ADS 2011 *.subst files.

The name of the *.subst file is appended as a suffix to the material name, to avoid side
effects on other material definitions in the same file.
Known limitations: The m/matl tool was originally designed for Sonnet stackup files, and
supports metals that have the same thickness as the dielectric they are embedded into, or
even penetrate into the dielectric above. This is valid in Sonnet, but not valid in ADS 2011.
In the present version, m/matl exports the metal thickness as you have defined it, and does
not fix possible metal thickness violations. Invalid metal thickness will be reported as an
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error by the ADS substrate editor. You, the user, should make sure that you define metal
thickness that is valid in ADS. One feature that might help you is the merging of dielectric
into a new thick dielectric with the equivalent permittivity, as described in chapter 5.

Import *.slm from Agilent ADS 2009 Momentum
*.slm is the file format used by Agilent ADS version 2009 and earlier. It is a single file
which has all the EM stackup information for the ADS Momentum EM simulator.
The *.slm already includes the stack-up position and layer mapping information.
Some differences exist in the definition of thick metal between Momentum and Sonnet.
These should be handled automatically in many cases, but you should always check the
result after import.

Import *.subst from Agilent ADS 2011
*.subst is the file format used by Agilent ADS version 2011 and later. The file does not
include the full EM stackup information, and references the shared material definitions file.
That shared material definitions file is always called materials.matdb and is located in the
same directory as the *.subst file.
Note that *.subst option thick metal expansion down is not supported at the present time.
Also, finite dielectrics (dielectric vias) for the FEM solver are not supported.

Import from Assura Procfiles
You can import substrate information from existing Cadence Assura procfiles.
To use this option, use File > Import and select an Assura procfile. The software will
evaluate the procfile, and also try to find and evaluate two additional files in the same
directory: p2lvsfile and lvsfile. If these additional files are not available, the via information
is missing and you need to set the via layout (from… to …) manually.
Unfortunatly, the layer names used in the Assura files do not always agree with the layer
names used in the layout editor. During import, m/matl tries to figure out the layer names,
as best as it can. Sometimes, this is not possible and you need to set the correct Cadence
layer names manually.
Important limitations for using Assura procfile import:
It is important to understand that the substrate itself is not included in any of these files.
The substrate thickness, permittivity and conductivity are added based on m/matl default
values. These default values can be set with File > Preference > Assura Import Settings.
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In this dialog, there is also a settings for via conductivity. The via conductivity might be
defined in the Assura files, or it might be missing. If the information is missing, the default
will be used and this default assigment is listed in the import summary message.
Another note in the import summary message is related to the deposition steps. At the
surface of the substrate, there are multiple deposition steps 1 defined, for different areas
of the chip. The m/matl import uses only the first line for deposition step 1, which is usually
for field oxide, and skips the other deposition step 1 entries. These skipped lines are listed
in the import summary message.

For metal sheet resistance specified in the p2lvsfile as (Ri,wi) pairs for width dependent
sheet resistance, m/matl uses the last entry, which is supposed to be valid for widest metal
traces.1
Carefully check your results! The Assura import has been tested and optimized with many
different design kits. However, there is some “educated guess” required in some cases,
especially for layer names. If you experience problems, please let us know!

1

From the Assura documentation: “Additionally, the (ri,wi) pairs should be specified in
order of increasing width.”
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3. Editor window and preview window
When you load in a file, two windows are shown: the editor window and the preview
window. The editor window is the place where you can apply modifications, and has
several "tabs" for dielectrics, metals, vias and file view. The preview window shows a
graphical representation of the stack-up.

You can re-arrange the windows by using the Window menu or the Tile/Cascade icons.
When you try to close a preview window, it is only minimized. To actually close a file, you
have to close the editor window.
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4. Preview settings
For preview, you can choose between "fixed height" view and "semi-proportional height"
view. This setting is found in File > Preferences > Display Settings.

Fixed height view
With "fixed height" view, all dielectrics are shown with the same height, no matter what
their physical thickness is. Metals that have the same thickness as the dielectric are shown
over the full height of the dielectric. Metals that are thinner than the dielectric are shown
with half the dielectric height. Metals that are thicker than the dielectric penetrate into the
dielectric above.

Semi-proportional height
With "semi-proportional height" view, you can visualize the differences in dielectric
thickness and metal thickness. However, limits apply for very thin dielectrics (such as MIM
layers) and very thick dielectrics (such as the substrate or air above), to obtain a nice and
clean view without. You can set the effective display thickness limit that is applied to very
thick and very thin layers.

Metal Loss Property
In the Display settings dialog, you can choose if metal loss is shown in the preview window
as conductivity [S/m] or sheet resistance [mOhm/square].

Zoom

Use the Zoom in, Zoom out and Zoom all icons to select the desired level of detail for the
stack-up preview. Some dimensions will be hidden if the zoom level is too small.
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5. Dielectric Layers
The dielectrics tab of the editor window shows a list of all dielectrics and their properties.
The order of the list corresponds to the physical position in the stack-up.

Edit dielectric
To edit a dielectric, double click on an entry in the dielectric table, or double click on a
dielectric in the preview window. This will bring up the "Edit" dialog.
For conducting dielectrics, e.g. the substrate, you can choose if you want to specify the
conductivity as [S/m] or specify the resistivity as [Ohm*cm]. Your input will be converted
to the format that Sonnet uses internally.

Add new dielectric
To add a new dielectric, select an existing dielectric in the editor window, or in the
preview, and the use "Add dielectric above" or "Add dielectric below".
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Split dielectric
You can split an existing dielectric layer into two pieces. This can be done, for example, if
you prefer a stack-up where thick metals have their "own" dielectric, instead of
penetrating partially into the dielectric above.
To split a dielectric, select it in the editor window or in the preview window, and then click
on the "Split dielectric" icon, or use the right mouse button menu. You will be prompted
how you want to split. If there is a thick metal defined on that dielectric, you can choose to
split into a metalized and a non-metalized part.

Merge dielectrics
This is the opposite of splitting: you can also combine two dielectric layers into one. To do
so, use the editor window to select the dielectrics that you want to merge (multi-selection
in the dielectrics table), and then click on the "Merge dielectrics" icon.

The resulting dielectric will be called "merged" and the new permittivity r will be
calculated based on the effective vertical permittivity. This ensures that a plate capacitor
would still see the same vertical permittivity r after merging.
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6. Metals
The metals tab of the editor window shows a list of all metals and their properties.

For metals, the list order does not have any effect on results. If you prefer to change the
list order, you can use the "Move up" or "Move down" icons.

Edit metal
To edit a metal, double click on an entry in the metal table, or double click on a metal in the
preview window. This will bring up the "Edit" dialog.
In the "Mapping and position" section, you can set the Cadence/ADS layer name for this
metal, and the position in the stack-up. If these two settings are not defined, the definition
is stored in the *.matl file as a "MATERIAL" entry instead of "METAL" entry, and can be
mapped later in the Cadence/ADS interfaces.
The material name is only a name used internally in Sonnet. By default, when you assign
the Cadence layer name, this will also set the material name to the same value.

11

Dr. Mühlhaus Consulting & Software GmbH
www.muehlhaus.com
info@muehlhaus.com
For the metal losses, you can specify conductivity σ in [S/m] or DC sheet resistance in
[ohm/square]. The sheet resistance is calculated as 1/(σ * thickness).
If you want to define a lossless metal, you can type "INF" for the conductivity, or set sheet
resistance to zero. For lossless metal, the thickness may be defined as 0 µm. For lossy
metal, you must assign a valid thickness value.
The Sonnet metal model - normal (thin) metal or thick metal model - can be set with the
drop down list at the bottom of the dialog. If the *.matl file was imported, it might also
contain some other, unusual metal definitions, which are then shown in the drop down list.
The fill type is set in the bottom drop down list. Typically, this is set to default, so that the
actual mesh type (staircase or conformal) for that layer is determined by the setting in the
Cadence/ADS interface. If the fill type is fixed to "Staircase" or "Conformal", instead of
"Default", then this value will always be used for this metal/layer, regardless of the setting
in the Cadence/ADS interface.
For use with GDSII and DXF, you can also set GDSII and/or DXF layer names. Just change
the layer name drop down list to "GDSII layer" or "DXF layer" and type in the value. If at
least one DXF or GDSII layer is defined, the corresponding column will also be shown in
the metal table.

Add new metal
In the metal tab of the editor window, you can use "Add" to add a new metal. By default, it
is appended at the end of the metal list. You can use the "Move up" or "Move down" icons
to move the metal in the list. This has no effect on the physical position in the stack-up. To
change the physical position in the stack-up, edit the metal and assign a different position.

Add new metal here
If you have selected a dielectric in the preview window, you can use the right mouse
button menu to bring up the "Add new metal here" command. This adds a new metal, and
already sets the metal position to that dielectric layer.
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Clone metal
The clone metal command creates a copy of the selected metal, with the same thickness
and conductivity and mesh properties. You only need to set Cadence/ADS layer and the
position in the stack-up.
This command can be useful if you have imported a *.son file, where one metal definition is
shared between multiple positions in the stack-up. In the *.matl file format, each metal can
only have one unique position in the stack-up. Thus, you might need to clone a metal
definition before you can use it in multiple positions.

Metal display in the preview window
In the preview window, metal is shown with the corresponding Cadence/ADS layer name,
and the loss specification. The loss specification can be [S/m] or [mOhm/square],
depending on your settings in File > Preferences > Display settings.

If a thick metal partially penetrates into the dielectric, the thickness of the metal and the
remaining dielectric thickness above are shown, if the zoom level permits.
If the metal name is shown with yellow highlighting, this means that the Cadence/ADS
layer name was not assigned. In this case, the material name will be shown instead of the
layer name, with yellow background color. To create a valid *.matl file, you need to assign
the Cadence/ADS layer name.
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7. Vias
The vias tab of the editor window shows a list of all vias and their properties. If at least
one DXF or GDSII layer is defined, for use with these file formats, then the corresponding
column will also be shown in the via table.

For vias, the list order does not have any effect on the output files. If you prefer to change
the list order, you can use the "Move up" or "Move down" icons.

Edit via
To edit a via, double click on an entry in the via table, or double click on a via in the
preview window. This will bring up the "Edit" dialog.
In the "Mapping and position" section, you can set the Cadence/ADS layer name for this
metal, and the from-to position in the stack-up. If these two settings are not defined, the
definition is stored in the *.matl file as a "MATERIAL" entry instead of "METAL" entry, and
can be mapped later in the Cadence/ADS interfaces.

If you want to create output files for Sonnet version 12, your vias must be defined with
wall thickness. Solid and array vias are only supported for Sonnet 13 or later.
14

Dr. Mühlhaus Consulting & Software GmbH
www.muehlhaus.com
info@muehlhaus.com
To simplify the from-to layer choice, the drop down list will display the dielectric levels
along with the name of the metal that is placed on this level. However, for thick metal that
fills a complete dielectric, the via can start at the top of the thick metal, which is actually
one level above the base of the thick metal.

Note: If a via is defined to go down to the bottom of a thick metal, like levels 3-5 in the
example above, the part of the via that is inside the thick metal will not be shown in the
stack-up preview. This is to ensure a clean view.

Via calculator
If you have chosen a “Solid via”, you can open the via calculator by clicking on the small
calculator icon located at the right side of the Conductivity input field. This calculator will
help you to convert via resistance and dimensions from the datasheet to the corresponding
conductivity value. Of course, if you already know the conductivity, you can type it in
without using the calculator.

15

Dr. Mühlhaus Consulting & Software GmbH
www.muehlhaus.com
info@muehlhaus.com

Add new via
In the via tab of the editor window, you can use "Add" to add a new via. By default, it is
appended at the end of the via list. You can use the "Move up" or "Move down" icons to
move the via in the list. This has no effect on the physical position in the stack-up. To
change the physical position in the stack-up, edit the via and assign a different position.

Add new via here
If you have selected a dielectric in the preview window, you can use the right mouse
button menu to bring up the "Add new via here" command. This adds a new via, and
already sets the via from-to position to that dielectric layer.

16

